Login | Register
My pages Projects Community openCollabNet

gef
Reply to message

* = Required fields
* Subject
* Body
Attachments
Send reply to
Topic
Author (directly in email)
Please type the letters in the image above.

Original message

Author =?ISO-8859-2?Q?Horv=E1th_Zsolt?= <horvath.zsolt@szilank.hu>
Full name =?ISO-8859-2?Q?Horv=E1th_Zsolt?= <horvath.zsolt@szilank.hu>
Date 2005-08-24 02:10:29 PDT
Message Hi Bob!

Thanks for your answer!

I have done the way which you tell to me about the GraphListener, but it
gets only the DefaultGraphModel as a parameter in the method
edgeRemoved, and from this object I can't bind out
the edge which is deleted. So now I use the edge deleteFromModel method
to catch this event. Of course it would be good if I can place these
events in one class (GraphListener)...

Thanks again: HZs

Bob Tarling wrote:

>CmdRemoveFromGraph only removes the view of the Fig but will leave the
>model item in existence. This is fine so long as your application only
>relies on the view.
>
>I've started to investigate this. In the meantime you may wish to
>experiment with adding a GraphListener to your GraphModel to see if
>you get the required events from that.
>
>Regards
>
>Bob.
>
>On 8/24/05, Horv├íth Zsolt <horvath.zsolt@sz​ilank.hu> wrote:
>
>
>>Hi!
>>
>>The problem is solved:
>>
>>I use CmdRemoveFromGraph instead of CmdDeleteFromModel for the menu item
>>Delete. Now it works fine.
>>
>>HZS
>>
>>
>>
>>>Hi!
>>>
>>>I have to catch the event when an edge is deleted from the diagram.
>>>First I have tried it with the demo application, so I have taken the
>>>SampleEdge, SampleEdge2 classes and I have extend the deleteFromModel
>>>method like the followin:
>>>
>>> public void deleteFromModel() {
>>> System.out.println("Delete from model: SampleEdge2.");
>>>super.de​leteFromModel();
>>> }
>>>
>>>When I press the delete key when this edge is selected, it is deleted,
>>>but I can't see the message in the console. So I can't catch the
>>>delete event. Same problem is in my own appliclation.
>>>This workflow working absolutely fine with nodes. So I don't
>>>understand what is the problem.
>>>
>>>Thanks: Zsolt
>>>
>>>
>>>--------​--------------------​--------------------​--------------------​-
>>>To unsubscribe, e-mail: users-unsubscribe@ge​f.tigris.org
>>>For additional commands, e-mail: users-help at gef dot tigris dot org
>>>
>>>
>>>
>>------------​--------------------​--------------------​-----------------
>>To unsubscribe, e-mail: users-unsubscribe@ge​f.tigris.org
>>For additional commands, e-mail: users-help at gef dot tigris dot org
>>
>>
>>
>>
>
>----------------​--------------------​--------------------​-------------
>To unsubscribe, e-mail: users-unsubscribe@ge​f.tigris.org
>For additional commands, e-mail: users-help at gef dot tigris dot org
>
>
>