Login | Register
My pages Projects Community openCollabNet

gef
Reply to message

* = Required fields
* Subject
* Body
Attachments
Send reply to
Topic
Author (directly in email)
Please type the letters in the image above.

Original message

Author bobtarling
Full name Bob Tarling
Date 2004-12-22 03:46:25 PST
Message I would like some feedback from the user community on what JRE's are
currently required to be supported by GEF.

GEF currently support JRE1.3 onwards. It may well work for JRE1.2 but
I haven't done any testing.

What are the JRE versions that existing GEF users must be able to target?

With development of GEF I am considering allowing some new JDK5
keywords but compiling with "javac -target 1.3". This should mean I
can use some of the new language features of JDK5 that will create
bytecode compatible with JRE1.3 (so new for each syntax but no assert
and no generics).

Obviously I will not be able to use classes and methods introduced after JDK1.3.

Should JRE1.3 remain the lowest target for GEF? Does that requirement
really exist out there? I would like some day to move forward to use
methods and classes from JDK1.4 within GEF code.

Regards

Bob.

--------------------​--------------------​--------------------​---------
To unsubscribe, e-mail: users-unsubscribe@ge​f.tigris.org
For additional commands, e-mail: users-help at gef dot tigris dot org